Impossible de redémarrer samba, samba.service est masqué


100

Lorsque j'essaie de redémarrer Samba, je reçois le message d'erreur suivant:

Failed to start samba.service: Unit samba.service is masked.

De plus, lorsque je cours systemctl, il est smbd.serviceaffiché en rouge et a échoué.

Au même moment où le redémarrage a commencé à échouer, j'ai perdu la possibilité de partage dans les dossiers créés et je ne peux pas y accéder. Toute aide serait appréciée!!!

Réponses:


149

Debian et les dérivés de Debian ont changé le nom du service de 'samba' en 'smbd'.

Essayez service smbd restart.


Quelqu'un sait pourquoi?
— Ben Creasy

3
@BenCreasy probablement parce que le nom du protocole est smb, et puisqu'il s'agit d'un démon, vous obtenez smbd. Samba est le nom d'une des implémentations du smbprotocole.
— terdon

Le travail pour smbd.service a échoué car le processus de contrôle s'est terminé avec un code d'erreur. Voir "systemctl status smbd.service" et "journalctl -xe" pour plus de détails.
— Mahdi Rafatjah

31

Essayer:

sudo systemctl unmask samba
sudo systemctl enable samba
sudo systemctl restart samba


4
Cela a fonctionné pour moi avec un problème similaire avec mongodb sur Ubuntu 16 après la mise à niveau à partir de 14. J'ai changé la première ligne, cependant, pour systemctl unmask mongodb.service. Cela fait, le service mongodb status / start / stop fonctionne.
— SevakPrime

Échec du redémarrage de samba.service: L'unité samba.service est masquée.
— Mahdi Rafatjah

Cela a semblé fonctionner au début: smbd a redémarré correctement, aucun journal ni erreur, mais il était toujours impossible de se connecter à samba à partir d'une autre machine. La seule chose qui a fonctionné à la fin a été de désinstaller et de réinstaller samba
— amine

3

Cela fonctionne pour moi (serveur Ubuntu 16):

sudo rm /lib/systemd/system/samba.service 
sudo systemctl enable samba.service nmbd.service
sudo systemctl start samba

Trouvé à partir d' ici


J'ai eu les mêmes erreurs que l'OP lors de l'exécution d' Ubuntu 16.04.5 LTS . Cette solution a résolu le problème pour moi.
— kneeki

ouch ls -l /lib/systemd/system/samba.service lrwxrwxrwx 1 racine racine 9 mars 5 2018 /lib/systemd/system/samba.service -> / dev / null
— BozoJoe

2

J'ai eu le même problème sans raison apparente. Vérification des journaux J'ai constaté que Samba avait des problèmes avec les fichiers en cache (autorisations incorrectes). rm -R /var/cache/samba/*a fait le tour.


Le travail pour smbd.service a échoué car le processus de contrôle s'est terminé avec un code d'erreur. Voir "systemctl status smbd.service" et "journalctl -xe" pour plus de détails.
— Mahdi Rafatjah
En utilisant notre site, vous reconnaissez avoir lu et compris notre politique liée aux cookies et notre politique de confidentialité.
Licensed under cc by-sa 3.0 with attribution required.