Problème SSH après la mise à jour


9
Setting up openssh-server (1:5.3p1-3ubuntu7) ... 
Creating SSH2 RSA key; this may take some time ... 
Creating SSH2 DSA key; this may take some time ... 
start: Job failed to start

Impossible d'initialiser ssh, déjà essayé de réinstaller.

Le serveur SSH est démarré manuellement via /etc/init.d/ssh start

netstat -nlp montre qu'aucun service n'est en cours d'exécution sur le port TCP 22


Pourriez-vous préciser dans votre question si vous avez essayé de le démarrer manuellement, c'est sudo /etc/init.d/ssh start-à- dire , et si oui, cela a-t-il donné une erreur différente de celle lors de l'installation? De plus, vous voudrez peut-être installer nmapet exécuter nmap 127.0.0.1pour voir s'il existe déjà une instance de ssh en cours d'exécution et mettre le résultat dans votre question.
— Azendale

j'ai essayé de l'exécuter manuellement et j'ai obtenu la même chose
— Frielspak

Essayez de redémarrer le démon ssh manuellement, puis ouvrez /var/log/authet vérifiez en bas du fichier ce que les journaux montrent ...
— Pavlos G.

Réponses:


16

Pas sûr que ma solution soit bonne. Mais si vous voulez simplement démarrer votre serveur SSH puis résoudre votre problème plus tard, voici ma solution rapide:

start-stop-daemon --start --pidfile /var/run/sshd.pid --exec /usr/sbin/sshd -- -p 22

si alors vous verrez une erreur:

Missing privilege separation directory: /var/run/sshd

puis créez simplement ce répertoire manquant et essayez à nouveau la commande start-stop-daemon ci-dessus:

mkdir /var/run/sshd
chmod 0755 /var/run/sshd

cela m'a aidé à démarrer mon démon sshd.


1
Cela ne le corrige que pour la session en cours. Après un redémarrage, ce répertoire disparaîtra.
— Malfist

2
dans le fichier /etc/init/ssh.conf ajoutez dans la section script de pré-démarrage la ligne suivante: "mkdir -p -m0755 / var / run / sshd"
— achabahe

4

J'ai eu le même problème qui sshdne démarre pas à cause d'une erreur.
Cela montrait qu'il n'y avait pas de répertoire /var/run/sshd.

ll  /var/run

a montré un lien vers /run.
Mais sur mon système /runfonctionne sur ramdisk.
J'ai donc supprimé le lien et créé les répertoires /var/runet /var/run/sshd. Maintenant sshd, ça démarre normalement et je peux à nouveau rejoindre mon système ssh.


1

reconfigurer mon pare-feu pour autoriser le port 22 a fonctionné pour moi.

ufw enable
ufw allow 22

0

Il semble y avoir 3 problèmes entraînant ce comportement (pour mon système Ubuntu 14.04LTS):

1- Un travail ssh inconnu se produit lorsque vous essayez d'utiliser le 'service ssh start' à partir d'une session 'su'. La solution consiste à utiliser le service sudo start à partir d'un utilisateur connecté qui peut 'sudo'

2- Le script init.d / ssh existant se termine tranquillement sans réellement démarrer sshd lorsque ssh est sur upstart

3- La principale raison pour laquelle ssh ne démarre pas est que sur Ubuntu 14.04 il y a un fichier vide / etc / ssh / sshd_host_not_to_run qui indique que sshd ne doit pas s'exécuter. Supprimez simplement ce fichier si vous voulez que sshd s'exécute.

La solution globale est donc la suivante: utilisez sudo service ssh start après avoir supprimé / etc / ssh / sshd_host_not_to_run


0

Réinstallez simplement openssh-server:

sudo apt-get install --reinstall openssh-server

En utilisant notre site, vous reconnaissez avoir lu et compris notre politique liée aux cookies et notre politique de confidentialité.
Licensed under cc by-sa 3.0 with attribution required.