Qu'est-ce qui entraînerait l'échec de «ping localhost»?


9

le fichier / etc / hosts contient une ligne: 127.0.0.1 localhost donc localhost doit être un nom d'hôte valide, mais toute tentative de connexion à un port sur localhost échoue, y compris ping.

Les tentatives de connexion à l'extérieur de ce serveur, en utilisant les mêmes clients, fonctionnent.

Les tentatives de connexion de ce serveur à d'autres serveurs utilisant ces clients fonctionnent également.

Lors d'une enquête plus approfondie, il échoue également à envoyer une requête ping à l'ip de bouclage 127.0.0.1 lorsque ping est invoqué directement sur cette adresse IP. En plus du ping, j'ai testé avec 'socat TCP4 ..'.

Une mauvaise iptables empêcherait-elle une connexion localhost?

Réponses:


7

Y a-t-il une interface configurée avec lo0ou toute autre interface avec 127.0.0.1? Vérifiez le nombre de paquets Rx / Tx. Vérifiez également si lo0 est configuré dans / etc / network / interfaces.

output of 'ifconfig'
lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:24 errors:0 dropped:0 overruns:0 frame:0
          TX packets:24 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:1440 (1.4 KB)  TX bytes:1440 (1.4 KB)

2
@dkeeney - Apparemment, cela a résolu votre problème, mais je ne peux pas comprendre quelle partie était pertinente. Peux-tu élaborer?
— belacqua

4

Oui, iptables peut pare-feu localhost de lui-même. Si vous avez joué avec ça, ce serait un excellent endroit pour regarder en premier.

Essayez de courir iptables -L -n. Si vous ne savez pas comment lire la sortie, postez-la.

Une erreur classique consiste à définir la stratégie sur DENY et à ne pas ajouter d'exception pour localhost.


Une règle POSTROUTING dans la table NAT m'empêchait d'envoyer une requête ping à localhost.
— pylover

1

Est-ce que «ip neigh show» montre que l'interface de bouclage est active?

Oui, il est possible de configurer iptables de manière à supprimer tous les paquets reçus sur lo. Je ne sais pas comment cela pourrait se produire par accident, mais cela vaut la peine de vérifier.


0

Vous pourriez regarder dans /etc/resolv.conf, mais je ne sais pas quelle entrée empêcherait localhost de fonctionner.


Le fichier resolv.conf est assez ordinaire, avec quelques lignes de serveurs de noms. Merci.

1
Il a dit qu'il ne pouvait pas non plus envoyer une requête ping par adresse IP, donc je doute que ce soit lié à resolv.conf.
— belacqua

Cette information a été ajoutée plus tard. Oui.
— utilisateur inconnu
En utilisant notre site, vous reconnaissez avoir lu et compris notre politique liée aux cookies et notre politique de confidentialité.
Licensed under cc by-sa 3.0 with attribution required.