le montage de webdav échoue au redémarrage


10

j'ai un vhost exécutant Ubuntu 12.10. j'ai installé davfs2 et édité mon /etc/fstabfichier comme suit:

https://somedomain.de/webdav.php/somefolder/ /mnt/s02 davfs defaults 0 0

maintenant ce montage en utilisant mount -afonctionne bien. aussi si je tape rebootaprès la connexion en utilisant ssh sur mon vhost en tant qu'utilisateur root, mon lecteur est monté correctement.

mais en utilisant le web-backend de mon fournisseur (digitalocean) et en cliquant sur "reboot", j'obtiens une erreur après le démarrage de ma machine:

échec de démarrage

des idées pourquoi cela se produit et comment y remédier?

Réponses:


16

L'erreur Could not resolve hostname 'hostname.de': host not foundsignifie probablement que le réseau n'est pas actif lors de la tentative de montage.

Il est recommandé de définir l' _netdevoption de montage qui signifie: le périphérique nécessite que le réseau soit disponible . De cette façon, il attendra qu'un lien soit disponible avant d'essayer de monter:

https://somedomain.de/webdav.php/somefolder/ /mnt/s02 davfs defaults,_netdev 0 0

♥ fonctionne comme un charme. Merci! vaut vraiment la peine.
— choix le

terminé. pensait que cela se
— produisait

J'ai sauvé mes jours. Il s'agit d'une option de montage rarement mentionnée davfsalors qu'elle nécessite souvent une connexion réseau pour être disponible.
— Omid
En utilisant notre site, vous reconnaissez avoir lu et compris notre politique liée aux cookies et notre politique de confidentialité.
Licensed under cc by-sa 3.0 with attribution required.