InnoDB: ignorer le journal de rétablissement en raison de MLOG_CHECKPOINT manquant


10

Je travaille avec mysql version 5.7.14 (installation homebrew sur OS X El Capitan). Mon système ne s'est pas arrêté correctement pendant que mysql était en cours d'exécution et après le redémarrage lorsque j'essaie de démarrer le démon mysql, j'obtiens les erreurs ci-dessous.

2017-02-07T10:11:42.224506Z 0 [Note] mysqld (mysqld 5.7.14) starting as process 18234 ...
2017-02-07T10:11:42.227375Z 0 [Warning] Setting lower_case_table_names=2 because file system for /usr/local/var/mysql/ is case insensitive
2017-02-07T10:11:42.228809Z 0 [Note] InnoDB: Mutexes and rw_locks use GCC atomic builtins
2017-02-07T10:11:42.228821Z 0 [Note] InnoDB: Uses event mutexes
2017-02-07T10:11:42.228826Z 0 [Note] InnoDB: GCC builtin __atomic_thread_fence() is used for memory barrier
2017-02-07T10:11:42.228830Z 0 [Note] InnoDB: Compressed tables use zlib 1.2.3
2017-02-07T10:11:42.229114Z 0 [Note] InnoDB: Number of pools: 1
2017-02-07T10:11:42.229227Z 0 [Note] InnoDB: Using CPU crc32 instructions
2017-02-07T10:11:42.230512Z 0 [Note] InnoDB: Initializing buffer pool, total size = 128M, instances = 1, chunk size = 128M
2017-02-07T10:11:42.239632Z 0 [Note] InnoDB: Completed initialization of buffer pool
2017-02-07T10:11:42.270103Z 0 [Note] InnoDB: Highest supported file format is Barracuda.
2017-02-07T10:11:42.270567Z 0 [ERROR] InnoDB: Ignoring the redo log due to missing MLOG_CHECKPOINT between the checkpoint 44002250712 and the end 44002250240.
2017-02-07T10:11:42.270606Z 0 [ERROR] InnoDB: Plugin initialization aborted with error Generic error
2017-02-07T10:11:42.577436Z 0 [ERROR] Plugin 'InnoDB' init function returned error.
2017-02-07T10:11:42.577470Z 0 [ERROR] Plugin 'InnoDB' registration as a STORAGE ENGINE failed.
2017-02-07T10:11:42.577484Z 0 [ERROR] Failed to initialize plugins.
2017-02-07T10:11:42.577488Z 0 [ERROR] Aborting

J'ai essayé de redémarrer mysqld innodb-force-recovery=1sans succès. Quelqu'un peut-il me guider sur la façon de se remettre de cet état?


Tu as de la chance ici? Je suis bloqué exactement sur le même problème.
— MMagicien du

Réponses:


16

Essayez ce qui suit:

  1. Réglez innodb_log_checksums = ONsur maître et esclave.
  2. Retirez rm /var/lib/mysql/ib_logfile*.
  3. Redémarrer.

En supprimant ib_logfile, vous perdrez vos données.
— digz6666

@ digz6666 qu'est-ce qui vous fait dire cela?
— Brian Leishman

@BrianLeishman essayez-vous avec des données de démonstration :)
— digz6666

2
@ digz6666 Je l'ai fait avant de commenter, cela a très bien fonctionné, rien n'a été perdu, et la DB a démarré tout de suite lol
— Brian Leishman

1
Pour référence, j'ai également testé cela (sur WAMP cependant) et il a récupéré la base de données. Aucune donnée n'a été perdue.
— Jeff F.
En utilisant notre site, vous reconnaissez avoir lu et compris notre politique liée aux cookies et notre politique de confidentialité.
Licensed under cc by-sa 3.0 with attribution required.