Unix & Linux

Q & A pour les utilisateurs de Linux, FreeBSD et d'autres systèmes d'exploitation de type Un * x



9
Comment configurer `umask` pour toute la session gnome?
Utiliser Gnome 3.18. Je partage des fichiers entre d'autres membres de la famille, mais le umask par défaut sur ma distribution (archlinux) est 0022. Ainsi, chaque fichier / répertoire créé n'est pas accessible en écriture pour notre groupe commun. J'ai essayé de mettre umask 0002en /etc/profilemais la session gnome utilise …
10 gnome3  umask 

2
Autorisations utilisateur dans le répertoire monté NFS
J'ai oracle linux 6.7, un serveur NFS sous Windows, et j'essaie de monter un dossier partagé sous Linux. Le serveur Windows NFS a un montage partagé: 192.168.1.10:/OracleBK Dans mon serveur oracle linux, j'ai créé un dossier, / orabackup et l'utilisateur oracle du groupe oinstall est le propriétaire de ce dossier: …
10 nfs 

3
pv (barre de progression) et gzip
Pourquoi n'est-ce pas possible? pv ${dest_file} | gzip -1 pv est une barre de progression Erreur gzip: compressed data not written to a terminal. Use -f to force compression. For help, type: gzip -h 0 B 0:00:00 [ 0 B/s] [> ] 0% Cela marche pv ${file_in} | tar -Jxf …


1
Système de fichiers Linux peu encombrant pour disque de musique?
J'ai un ancien SSD dans mon ordinateur portable plein de données statiques, principalement FLAC et quelques fichiers zip, il y a très peu de fichiers de moins de 10 Mo et les écritures sont également hebdomadaires plutôt que multiples par seconde. Je suis réticent à acheter un nouveau disque hérité …
10 filesystems  flac 

2
«Canal 3: échec d'ouverture: administrativement interdit: échec d'ouverture» lors de la création d'une session VNC sur un tunnel SSH
Lors de la création d'une connexion VNC via une connexion SSH tunnelée, j'obtiens une erreur: channel 3: open failed: administratively prohibited: open failed J'ai constaté que cela ne se produit que lorsque je ne suis pas connecté à l'hôte localement en tant que usernamesur l'hôte auquel j'essaie de me connecter …

1
Le serveur X ne démarre qu'en tant que root
J'ai un système Arch Linux, un noyau de stock et des pilotes. Pour une raison étrange, xinit génère une erreur lorsqu'il est démarré par un utilisateur non root. Les journaux disent ceci: (EE) parse_vt_settings: Cannot open /dev/tty0 (No such file or directory) Cependant, je peux statet lsle fichier de l'utilisateur …

1
Gérer les unités systemd d'un autre utilisateur
Un utilisateur, ou peut-être root, peut-il contrôler les services systemd d'un autre utilisateur? Je l' ai essayé sudo -u <some user> systemctl --user restart <some service>, mais il se plaint dbus sur: Failed to get D-Bus connection: Connection refused.
10 sudo  systemd 


1
Pourquoi ffmpeg a-t-il été supprimé de Debian?
Actuellement, il ffmpegmanque dans les paquets APT lors de l'utilisation des versions stables de Debian et Ubuntu. Il existe de nombreuses ressources ( exemple de SuperUser , une autre de la documentation de Debian et celle d'AskUbuntu ) qui expliquent comment l'installer d'une manière différente (et plus complexe) qu'une simple …
10 debian  ffmpeg 

1
Nano Editor: supprimer jusqu'à la fin du fichier
Lors de l'utilisation du Nano Editor de GNU , est-il possible de supprimer de la position réelle du curseur jusqu'à la fin du fichier texte? Ma solution de contournement pour l'instant: maintenez enfoncé CtrlK(le raccourci de suppression de la ligne complète ). Mais cette méthode n'est pas si confortable sur …
10 nano 

2
Puis-je désactiver la mise en mémoire tampon pour tr
trsemble mettre en mémoire tampon son entrée afin que cette commande LongRunningCommand|tr \\n ,ne commence à produire une sortie qu'après l'accumulation de quelques kilo-octets d'entrée de LongRunningCommand. Existe-t-il un moyen de forcer l' trarrêt de cette mise en mémoire tampon ou toute autre commande pouvant remplacer les sauts de ligne …
10 tr 


En utilisant notre site, vous reconnaissez avoir lu et compris notre politique liée aux cookies et notre politique de confidentialité.
Licensed under cc by-sa 3.0 with attribution required.