logstash-forwarder a échoué à tls Handshake ne peut pas valider le certificat car il ne contient aucun IP SANS


3

J'ai un serveur logstash / élastique recherche / Kibana sur Ubuntu 14.x 64bit.

J'ai quelques autres serveurs avec les mêmes spécifications en utilisant logstash-forwarder, et tout fonctionne comme prévu.

Cependant, lorsque je configure un serveur centos 6 32 bits, avec une configuration comme:

lien vers exemple de configuration

J'ai l'erreur suivante:

Failed to tls handshake with x.x.x.x x509: cannot validate certificate for x.x.x.x because it doesn't contain any IP SANs

Si je change cette configuration et mets le DNS dans, au lieu de l'ip, j'obtiens l'erreur suivante:

Failed to tls handshake with x.x.x.x x509: certificate is valid for , not my-dns.com

toute orientation grandement appréciée ..

** UPDATE: Il semble que cela ne se produise pas sur un système 64 bits sur lequel je peux installer le rpm logstash-forwarder. Donc, le problème peut être dans la version 32 bits que j'ai téléchargée et compilée avec go.

Réponses:


6

J'ai résolu ce problème en générant un nouveau certificat sans le paramètre -batch. Cela signifie que le certificat a demandé le "nom commun" lors de sa génération.

J'ai mis le serveur logstash DNS comme nom commun, j'ai remplacé les anciens certificats par le nouveau et cela a fonctionné. Voici la commande que j'ai utilisée pour générer le nouveau certificat:

openssl req -x509 -nodes -newkey rsa:2048 -keyout logstash-forwarder.key -out logstash-forwarder.crt

N'oubliez pas de redémarrer le service logstash une fois que vous avez remplacé le certificat, de copier le nouveau certificat sur les clients et de redémarrer leurs redirecteurs logstash.
— Zymhan
En utilisant notre site, vous reconnaissez avoir lu et compris notre politique liée aux cookies et notre politique de confidentialité.
Licensed under cc by-sa 3.0 with attribution required.