Qu'est-ce que les programmes réseau utilisaient pour communiquer avant l'invention des sockets (vers 1983?)


14

Les sockets ont été inventées à Berkeley vers 1983, mais comment fonctionnaient les programmes informatiques en réseau avant cela? De nos jours, à peu près tout utilise des sockets, il est donc difficile pour moi d'imaginer comment d'autres programmes pourraient communiquer et Google n'a rien trouvé.


2
Avant les sockets en 1983, il n'y avait que "Sock it to me"
— Neil

En fouillant dans l'histoire, la spécification pour IP peut être trouvée dans la RFC 760 publiée en '80. TCP est dans RFC 761 . UDP provient de RFC 768 . En regardant les références de ceux-ci, vous voyez des choses telles que "Cerf, V. et R. Kahn," Un protocole pour l'intercommunication de réseau par paquets ", IEEE Transactions on Communications, Vol. COM-22, No. 5, pp 637- 648, mai 1974. "

Réponses:


15

Le socket Berkeley n'était qu'une API qui a été inventée à l'époque. La technologie qui élimine les résumés était déjà là; La pile ARPANET et TCP / IP a été inventée dans les années 70 et il y avait des réseaux informatiques avant cela.

Techniquement, vous pouvez connecter deux ordinateurs avec un câble série et les faire communiquer dessus.


1
+1, les ports, par exemple, sont antérieurs à l'API socket. Je pense que TCP (1974) a toujours eu le concept de ports.
— Jamie F

1
SLIP - Serial Line Internet Protocol , une technologie de numérotation courante dans la journée.

Beaucoup de développement de jeux pour les machines 8 bits (C64, ZX Spectrum) a été fait exactement de cette façon - le codage a été fait sur un PC ou similaire, puis envoyé à la machine 8 bits via des communications série.
— Alan B

Le P dans TCP est le protocole. Il y avait d'autres protocoles avant et en concurrence avec celui-ci, c'est une abstraction sur UDP qui l'a précédé. Encore une fois, P dans UDP étant Protocole; il y avait aussi des concurrents différents de l'UDP.
— Jimmy Hoffa

En utilisant notre site, vous reconnaissez avoir lu et compris notre politique liée aux cookies et notre politique de confidentialité.
Licensed under cc by-sa 3.0 with attribution required.