Magento2 a défini le mode de maintenance


10

J'active le mode maintenance en ajoutant un fichier var/.maintenance.flag, mais j'obtiens l'erreur:

Unable to proceed: the maintenance mode is enabled. 
#0 /backup/html/magento2/vendor/magento/framework/App/Bootstrap.php(256): Magento\Framework\App\Bootstrap->assertMaintenance()
#1 /backup/html/magento2/index.php(39): Magento\Framework\App\Bootstrap->run(Object(Magento\Framework\App\Http))
#2 {main}

J'ai même essayé de l'activer en utilisant la commande:

bin/magento maintenance:enable

En outre, activé le mode de production, effacé les caches, je ne reçois pas la page 503. Veuillez aider!

Réponses:


12

Le mode de maintenance signifie que le site Web est hors ligne.
Cela fonctionne donc comme prévu.
Si vous souhaitez supprimer le mode maintenance exécutébin/magento maintenance:disable


2
Ne devrait-il pas s'afficher: "Le serveur est temporairement incapable de répondre à votre demande en raison d'un arrêt de maintenance ou de problèmes de capacité. Veuillez réessayer plus tard." ie 503.phtml?
— Twinkal

Vous avez probablement raison. Mais pas sûr
— Marius

4
Cela ne répond pas à la question de l'exception.
— Robert Egginton

11

Mon MAGE_MODEétait défini comme développeur et j'avais déployé en production en utilisant:

php bin/magento deploy:mode:set production

en supposant qu'il s'agit d'un moyen dynamique de changer le mode développeur en production.

J'ai dû changer le MAGE_MODEpour productionou defaultobtenir la page 503.

J'adorerais connaître la différence entre MAGE_MODEet le mode de déploiement.


1
Je pense que les valeurs que vous définissez sur la configuration du serveur (comme MAGE_MODE) remplacent les valeurs de config.phpet env.php. C'est pourquoi votre mode développeur était activé même si vous le définissez différemment via cli.
— Marius

Vous avez raison !! .. Je ne trouve rien dans config.phpmais env.phpça change la MAGE_MODEvaleur basée sur la commande cli. Merci :)
— Twinkal

1

Vous pouvez essayer ça. Exécutez la commande suivante. (Comme je n'ai pas testé cela, veuillez créer une sauvegarde de votre Magento)

1) / bin / magento maintenanca: désactiver

Si Non résolu en utilisant la première commande et vous voyez une erreur comme " Le serveur est temporairement incapable de répondre à votre demande en raison de temps d'arrêt de maintenance ou de problèmes de capacité. Veuillez réessayer plus tard ". Dans ce cas, vérifiez ici .

2) Exécutez maintenant la commande :: / bin / magento maintenance: status
3) / bin / magento maintenance: enable


0

Lorsque vous êtes dans Magento developer mode-> puis activez maintenance mode-> vous obtiendrez le message d'erreur que vous avez décrit

Lorsque vous êtes dans un autre mode -> puis activez maintenance mode-> vous obtiendrez la page 503


1
Semble, peu importe le mode que vous utilisez, il montre toujours une exception.
— Kirby
En utilisant notre site, vous reconnaissez avoir lu et compris notre politique liée aux cookies et notre politique de confidentialité.
Licensed under cc by-sa 3.0 with attribution required.